Fitbit support advising installing Adobe Flash – yeah, no.

I’m just going to leave this Twitter link here. There are many reasons I am selling my Fitbit Sense, and this is yet another one.

TL;DR – the Twitter – Fitbit dashboard (web) is requesting I install of Adobe Flash, an app that has blocked in Chrome since December 2020, an app discontinued and no longer downloadable from Adobe (here’s the link it’s pointing to).

Since being a Sense owner the cable’s broken, the idle tracking is 30%+ after multiple resets and jumping through hoops…

I mean yeah, I get they’re not interested in investigating or helping or knowing their product… The fact that Google owns them and the app doesn’t work with Google Fit still astounds me. Well, actually probably not.

Issue is a web page, it’s obvious it’s a bug and 3+ year old CMS or something, I tried reporting it and got that. Yeah, let’s install software similar to Adobe Flash. I really did appreciate how their Twitter team turned and made it my fault for not having Adobe Flash. You know, not their parent company that blocked it, Microsoft that blocked it, Adobe which discontinued it.

Pocketables does not accept targeted advertising, phony guest posts, paid reviews, etc. Help us keep this way with support on Patreon!

Paul E King

Paul King started with GoodAndEVO in 2011, which merged with Pocketables, and as of 2018 he's evidently the owner. He lives in Nashville, works at a film production company, is married with two kids. Facebook | Twitter | Donate | More posts by Paul | Subscribe to Paul's posts